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Cellar Training:
Instructions to install Postman and
to import Cellar APl demo requests

This document contains the instructions for installation of Postman tool and for importing
a Postman'’s collection file for the purpose of Cellar Training.

Postman is a tool that developers and any other end-users can easily use to test and
familiarize with some particular APIs (Application Programming Interface) such as the
Cellar dissemination REST API.

For the purpose of Cellar training, we have prepared a collection of HTTP requests that
can be imported into Postman to demonstrate features of Cellar dissemination REST API.

1. Download Postman from EC Store or from Postman home page & install it

From EC Store: Start EC store from Apps and search for Postman in EC Store. Once
found, click on “Install” button. (If you see “Uninstall” button, that means that Postman
has been installed already on your machine)

All Apps Documents Settings More ¥

Best match

: 1-DWP EC Store

App

A
FPe 1-DWP EC Store

® EC Webcast Player [V5] App

== 3-Fix My EC-Print

Open

Run as administrator
Pin to Start

Pin to taskbar

App settings

Uninstall
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L ECSTORE 2430

E C Sto re 1 applcationts Current installations Refresh postmar|

Self Service

All applications

ACTION TITLE DESCRIPTION STATUS. Restricted
N G- Foson 3 b HTTp e 7 —_—
Installed
Not installed
Refine list by
@ “ All

Administration
Audio
Browsers

AL

© Business applications
Communication
Compression Utilities
Database
Development
Document management
Ebook
File explorer
Design

© Language
Media Player
Network
Office applications
Operations Management
PDF

From https://www.postman.com/downloads/

Download Postman release suitable for your machine e.g., for Windows 64-bit

9 Product ~  Pricing Enterprise v Resources and Support v~  Explore

Download Postman

Download the app to get started using the Postman API Platform today. Or, if you pre
browser experience, you can try the web version of Postman.

The Postman app Home Workspaces v API Network v Explore

Download the app to get started with the Postman API
Platform.

B8 Windows 64-bit

By clicking "Accept All Cookies”, you agree to the storing of cookies on
your device to enhance site navigation, analyze site usage, and assist in
our marketing efforts.

~ [ Databases
~h ' Params &  Authl  Hes

Run the downloaded file .exe file. Follow the instructions on screen.


https://www.postman.com/downloads/
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~ Name PO
# Quick access # Quick access Open File - Security Warning X
B Desktop  Today (1)
# Downloads @ Postman-win64-Setup.exe W Desktop ol
& Downloads | Do you want to run this file?
% Documents Yesterday (1)
= Documents »
& Pictures Earler this week (1) (i Download fSaTpe
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wort Last week (2) | Publisher: Postman, Inc.
testing Earlier this month (10) ek icati
) : Type: Application
april testing *
[] Last month (32) From:  C\U: load: 4
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Earlier this year (124)
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timesheets Aleng time ago (483) new-dev-env Bun
virtuoso timesheets
) Always ask before opening this file
@ OneDrive - European C virtuoso
i @, OneDrive - European
 This PC P While files from the Internet can be useful, this file type can
¥ 30 Objects  This PC potentially harm your computer. Only run software from publishers
you trust. What's the risk?
I Desktop ¥ 30 Objects
& Documents
B Desktop
¥ Downloads
. ol £ Documents
654items 1 item selected 159 MB ¥ Downloads
LI VR N S
654items 1 item selected 159 MB

After Postman is installed, you can open it from the Windows Start Menu.
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3. Create a Postman Account
When you start Postman, you'll need to create an account to import collections:

Follow the on-screen prompts to register in clicking to ‘Create Free Account’:

Create an account or sign in A free Postman account lets you
(2 Orgarize all your API develol it in WOrKEpaces
D te publ spaces 10 collaborats © million devs

Signin

The following screen will show up:

Create account via web
browser

If your browser hasn't opened Postman for you to
sign in, open it manually or copy the URL.

Enter authorization token to sign in

Postman will automatically open your default browser at the registration page.

If you prefer to use another browser, copy the URL, open your preferred browser, and
paste it into the address bar.
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The following screen will show up:

@

Sign in to Postman

Email or username

Password

Stay signed in Forgot password?

D Verify you are human

or

$ G Sign In with Google

Sign In with SSO

You've been redirected from the Postman Desktop App
on win32 10.0.19045 to sign in

Create free account

You can sign up with Google:

S Sign in with Google

Choose an accou =(>.ngn.com

to continue to Postman
® Use another account

Before using this app, you can review Postman’s privacy
policy and terms of service.
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Fill the information:

Welcome to Postman! Tell us a bit
about yourself.

Your name

What is your role?

Click on continue, and then you can:

- have automative redirection to your Postman application. In this case you can
directly go to part 3 (Configure Proxy settings for Postman).
- oryou can click on ‘use authorization token to signin’:

It's great to have you aboard,

Redirecting you to the Desktop App

If you aren't redirected automatically, use
authorization token to sign in.
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Then click on ‘Copy Token':

Use authorization token to sizn in
Authorization token
Paste this token in the Enter authorization token' field on the Desktop App.

postman:(msth/callbackTeode=41883:38049 7680 TeB0M3 Sbal 1bd
b3 2T 0 — )

=> B

Then go to the Postman app and click on ‘Enter authorisation token’ as indicated
before:

Sign in from your browser to continue

If your browser hasn't opened Postman for you to sign in, open it manually

C=> Enter authorization token

Paste the token previously copied:

Enter authorization token to sign in

To copy your token, select 'use authorization token to sign in’
on the browser

Enter authorization token

Paste token here

After this step, you should be connected.
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3. Configure Proxy settings for Postman (if necessary)

If needed (and it is needed if you are using Postman from EC laptop), please enter the
configuration for the proxy:

- Go to File->Settings

]
| «=._ Home Workspaces v  Explore Q) search Postman " @ Ssignin Create Account —_ O
& File » New.. Ctrl+N
it » New Tab CulsT &% Working locally in Scratch Pad. Switch to a Workspace
St View » New Runner Tab Ctrl+Shift+R brt Orerview + 4 No Environment “i
|
Help » New Postman Window  Ctrl+Shift+N
= ‘
- Import... Ctrl+O
Collect;
setens , = Scratch Pad
Settings Ctrl+Comma
o
0: Close Window Ctrl+Shift+W The Scratch Pad is for all your scrappy, exploratory work on Postman. All Get started
o the data is saved locally on your machine, so only you have access to it.
Close Tab Ctrl+W ; < &
To collaborate in real-time and sync your work, switch to a workspace. Create a request
= Force Close Tab Alt+Ctrl+W 9
Environments Exit In your Scratch Pad
B Create a collection
=] 449 0 0 S cre
Mock Sarvers You don't have any collections Hegiests Collecions Emvironments oo Create an API
Collections let you group related requests, = N
making them easier to access and run. D Create:an evironment
Monitors
Create Collection see View More
)
History
ED Q Find and Replace [ Console (@ Runner TN Trast

Go to Proxy tab and enter your username and password for proxy

SETTINGS

General Themes Shortcuts Data Add-ons Certificates Proxy Update About

Default Proxy Configuration

Postman uses the system's proxy configurations by default to connect to any online services, or to send API
requests.

This proxy requires authentication

Username username|

Password sessses

Save and restart Postman

Save the proxy configuration and restart Postman.
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3. Download & import a Cellar Training Collection into Postman

Now, please download a Postman collection file for Cellar Training:
- Go to https://op.europa.eu/en/web/cellar/documentation

- Click on "postman query collection” link

Cellar code

You can download the Cellar code.

Cellar training material

You can download the postman query

collection of the Cellar training.

You can download the slides of the Cellar
training (soon).

“CellarTraining.postman_collection.json”file will be downloaded to your
machine (e.g. into ../Downloads folder)

41 ~ | < | Downloads - m] X
rome  stare v ®
« v 4 & » ThisPC » Downloads » v D P Search Downloads
Name Date mo
s Quick access
v Today (1)
@ OneDrive - European Com y . L.
CellarTraining.postman_collection json 25/05/2C
> = This PC Yesterday (1)
@ Network Earlier this week (1)

Last week (2)

Earlier this month (10)
Last month (32)
Earlier this year (125)

Along time ago (484)

656 items =]

Now, please go back to Postman and import the
“CellarTraining.postman_collection.json™ file:

- Click Import button


https://op.europa.eu/en/web/cellar/documentation
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1 & Working locally in Scratch Pad. Switch to a Workspace

Scratch Pad New Import  Overview + e
O + =
CToE = Scratch Pad

000
The Scratch Pad is for all your scrappy, exploratory work on Postman. All

APIs ) : .
the data is saved locally on your machine, so only you have access to it.

& To collaborate in real-time and sync your work, switch to a workspace.

Environments

In your Scratch Pad

2 449 0 0
Mock Servers You don’t have any collections Requests Collections Environments
Collections let you group related requests,
making them easier to access and run.
Monitors

Create Collection
)

History

B  QFind and Replace Console

- Go to File tab and Upload File button

Import

File Folder Link Rawtext Code repository New

OpenAPI GraphQL

WSDL  New HAR  New

OR

Upload Files

Import
Select files toimport - 1/1 selected

NAME FORMAT IMPORT AS

CellarTraining Postman Collection v2.1 Collection

Cancel

(]
= Home Workspaces v  Explore Q search Postman & & signin E

Gets

&

Upload “CellarTraining.postman_collection.json” file and click on Import button

Date: 17 January 202
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And that's it! The Cellar Training collection has been imported into Postman.

]
= Home Workspaces v  Explore Q_ Search Postman « @ Ssignin H
&) Working locally in Scratch Pad. Switch to a Workspace
Scratch Pad New Import  Overview 4+ o N
0 + =
Collections
» [CHIEATaTS = Scratch Pad
S
The Scratch Pad is for all your scrappy, exploratory work on Postman. All Gets
s the data is saved locally on your machine, so only you have access to it.
To collaborate in real-time and sync your work, switch to a workspace. & d
=
Environments In your Scratch Pad
Ha
=) 449 1 o] 1
Mock Servers E 1
&l g
Monitors
000 \}
D
History

B0 QFind and Replace Console

Now you can browse the HTTP requests. For each requests you can click on the
‘Headers' (we will explain it during the training).

Try them by clicking on “Send"”.

= Home

Scratch Pad

5}

Collections

Environments

[=]

Mock Servers

]
Workspaces v Explore Q search Postman « @ signin Create Account -
& Working locally in Scratch Pad. Switch to a Workspace
New Import  G:T Request English PDFof =+ oo° No Environment v
+ | = ®°  CellarTr.. | Retrieve Content ... | Request English PDF of a publicatio v . Vas
v CellarTraining
v [ Retrieve Content Streams GET v http://publications.europa.eu/resource/cellar/b84f49cd-750f-11e3-8e20-01aa75ed7 Send v
GET Request English PDF of a publication (by Cellar id)
Params Auth Headers (9) Body Pre-req. Tests Settings Cookies
GET Request French XHTML of a publication
Query Params
GET Request Italian PDF of a publication (by OJ num)
KEY VALUE DESCRIPTION 000 Bulk Edit

GET Request German PDF of a publication (by Celex n...

GET Request Collection of publication as ZIP

GeT Request Collection of publication as ZIP (FORME...

Res -
Monitors GET Request Collection of publication as List
> [ Retrieve Notices XML
0]
e > 3 Retrieve Notices RDF
> [ Retrieve Identifiers
> [ Retrieve Feeds
Click Send to get a response
ED Q Find and Replace (& Console ® Runner

X

W m
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Results are shown in the Response / Body tab:

(J
= Home Workspaces v  Explore Q search Postman & &  Ssignin - X
&) Working locally in Scratch Pad. Switch to a Workspace

Scratch Pad New Import  GET Request English PDF of 4+ eoo No Environment v &

S| + = CellarTr.. | Retrieve Content ... / Request English PDF of a publicatio... < - s E B
Collections

v CellarTraining
& v [ Retrieve Content Streams GET v http://publications.europa.eu/resource/cellar/b84f49cd-750f-11e3-8e20-01aa75ed7 S
APIs

GET Request English PDF of a publication (by Cellar id)
Params Auth Headers (9) Body Pre-req. Tests Settings Cookies <>

GET Request French XHTML of a publication

Eovromments ) o Query Params
GET Request Italian PDF of a publication (by OJ num)
a GET Request German PDF of a publication (by Celex n... KEY VALUE DESCRIPTION e | BulkEdit
Mock Servers GET Request Collection of publication as ZIP Key Value cription
GET Request Collection of publication as ZIP (FORME... Body v @® 2000k 698ms 709.71KB  Save Response v
Monitors GET Request Collection of publication as List l
> [ Retrieve Notices XML
H:gy > [5 Retrieve Notices RDF 412014 OfficialJournal of the European Union L

>[5 Retrieve Identifiers I

> [ Retrieve Feeds

REGULATIONS

COMMISSION DELEGATED REGULATION (EU) No 1/2014
of 28 August 2013
establishing Annex Il to Regulation (EU) No 978/2012 of the European Parlizment and of the

E) QFindandReplace B3 Console ® Runner BH o
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